)

NomoLog

Log of my life and program

NeoBundleInstallでjedi-vimがインストールされない問題

Posted in Vim Tagged as Python

.vimrcNeoBundleInstal 'davidhalter/jedi-vim'を書き加えて:NeoBundleInstallしてもHTTP request failedと怒られてインストール出来ませんでした。

原因がよくわからなかったので、手動でjedi-vim入れて解決しました。手順は以下。


1. bundleフォルダ以下にgit cloneでjedi-vimを取ってくる

NeoBundleInstallで本来インストールされるべき場所に手動でjedi-vimを入れます。

1
2
cd .vim/bundle
git clone https://github.com/davidhalter/jedi-vim.git

2. jedi-vimフォルダ内でgit submodule

jedi-vimはjediをsubmoduleとして持っているのでgit submoduleでjediを更新してあげます。

1
2
cd jedi-vim
git submodule update --init

3. :NeoBundleUpdateする

.vimrc:NeoBundleUpdateしてみます。インストールし直しますか?と聞かれるのでNoを選択します

4. :h jediで動作確認

ちゃんとjedi-vimが動いていれば:h jediでjediのヘルプが見れます。

Comments